BestForum.RU форум для общения

Форум компьютер => FreeBSD форум => Тема начата: kurlyak от Август 07, 2009, 10:45:34 am

Название: Opera 9.64 и FreeBSD 5.2
Отправлено: kurlyak от Август 07, 2009, 10:45:34 am
Ставлю Оперу в ФриБСД потом запускаю и ругаеться что нету:
/libexec/ld-elf.so.1: Shared object "libm.so.3" not found
я так понимаю какие то либы надо установить? а в каких они пакетах? Кто- то подскажите.
Название: Opera 9.64 и FreeBSD 5.2
Отправлено: Snake от Август 07, 2009, 12:24:31 pm
Ставишь пакетом или из портов?
Как вариант попробуй: ln -s /lib/libm.so.3 /usr/local/lib/libm.so.2

P.S. Гугль это великая сила  ;)
Название: Opera 9.64 и FreeBSD 5.2
Отправлено: kurlyak от Август 07, 2009, 04:23:04 pm
Пробывал ln -s /lib/libm.so.3 /usr/local/lib/libm.so.2 все равно требует libm.so.3. Я вобще то сегодня первый раз поставил Фри БСД и не знаю откуда эта библиотекта. Оперу скачал в tar.bz2 с сайта Оперы.
Название: Opera 9.64 и FreeBSD 5.2
Отправлено: Snake от Август 08, 2009, 01:04:05 am
А почему тогда именно 5.2? Почему бы не поставить последний релиз 7.2?

В любом случае, ставить софт в фри лучше всего из портов - учитываются все зависимости упрощается процесс установки.

Для начала нужно обновить коллекцию портов[/a], чтобы иметь под рукой свежие версии ПО.

Установка проводится от рута

Затем устанавливаем оперу:
# cd /usr/ports
make search name="opera"

В появившемся списке выбираем подходящий порт (скорее всего лежит в /usr/ports/www)

в папке порта:

#make install clean

Установщик вытащит все нужные зависимости и поставит все необходимое (http://hotfreebsd.ru/obnovlenie-kollekcii-portov-freebsd/)
Название: Opera 9.64 и FreeBSD 5.2
Отправлено: kurlyak от Август 08, 2009, 08:21:55 am
Спасибо за помощь, просто у меня щас под рукой нету ФриБСД 7.2 только 5.2. А вобще советом воспользуюсь.
Название: Opera 9.64 и FreeBSD 5.2
Отправлено: StranNik от Август 09, 2009, 09:58:08 pm
От себя добавлю, что у меня лично со старыми версия особенно с 4 была куча проблем, наверное оттого, что у самого опыт небольшой. А в более новых версиях - ну хотя бы в 6 ветке таких проблем нет. Поищите в своем городе тех, кто может вам записать дистр со свежей версией FreeBSD - как правило это сделают бесплатно за сами болванки или за бутылку пива вовсе незнакомые вам люди :smile:. Достаточно спросить на местном форуме.
Название: Opera 9.64 и FreeBSD 5.2
Отправлено: kurlyak от Август 11, 2009, 05:28:58 pm
что вам сказать, господа. Погуглив я обнаружил, что libm.so.3 есть только в 6-й версии ФриБСД и находитсья в пакете compat5x. Естественно я со своим 5-м ФриБСД ничего сделать не смог. Хотя пакет этот скачал и установил эту либу. Заглючил ФриБСД себе. Но, потом я порылся в архиве сайта Опера и скачал Опера 9.24- работает у меня на ФриБСД 5.2 вроде хорошо, без глюков. Но еще тестирую. Правда плугины не находит. Но вобщим я доволен.
Название: Opera 9.64 и FreeBSD 5.2
Отправлено: StranNik от Август 11, 2009, 09:45:46 pm
Ну вот и решение нашлось. Спасибо, что поделились, уверен кому-нибудь еще это пригодится и поможет.  И все же получается если перейти на более актуальную версию FreeBSD, то с кучей проблем просто не встретишься.
Название: Opera 9.64 и FreeBSD 5.2
Отправлено: kurlyak от Август 14, 2009, 08:32:43 am
Да так дело в том, что вы представляете- оказываеться в релизе ФриБСД 7.2 есть уже встроенная опера 9.64. Надеюсь все плугины и Флешь плугин тоже там работет. Если бы еще был встроеный Флешь плугин было бы вобще классно.
Название: Opera 9.64 и FreeBSD 5.2
Отправлено: StranNik от Август 15, 2009, 09:55:58 pm
С flash и в линуксах и во фряхе  есть ряд проблем. Но все решаемо :smile:.