Автор Тема: Opera 9.64 и FreeBSD 5.2  (Прочитано 3009 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kurlyak

  • Newbie
  • *
  • Сообщений: 14
  • Карма: +0/-0
Opera 9.64 и FreeBSD 5.2
« : Август 07, 2009, 10:45:34 am »
Ставлю Оперу в ФриБСД потом запускаю и ругаеться что нету:
/libexec/ld-elf.so.1: Shared object "libm.so.3" not found
я так понимаю какие то либы надо установить? а в каких они пакетах? Кто- то подскажите.

Оффлайн Snake

  • СтуденТ
  • Hero Member
  • *****
  • Сообщений: 1990
  • Карма: +6/-0
    • БложеГ
Opera 9.64 и FreeBSD 5.2
« Ответ #1 : Август 07, 2009, 12:24:31 pm »
Ставишь пакетом или из портов?
Как вариант попробуй: ln -s /lib/libm.so.3 /usr/local/lib/libm.so.2

P.S. Гугль это великая сила  ;)
« Последнее редактирование: Август 07, 2009, 12:26:00 pm от Snake »
И самый лютый зверь, тот знает жалость... я жалости не ведаю... Так значит, я не зверь! (с) Шекспир

Оффлайн kurlyak

  • Newbie
  • *
  • Сообщений: 14
  • Карма: +0/-0
Opera 9.64 и FreeBSD 5.2
« Ответ #2 : Август 07, 2009, 04:23:04 pm »
Пробывал ln -s /lib/libm.so.3 /usr/local/lib/libm.so.2 все равно требует libm.so.3. Я вобще то сегодня первый раз поставил Фри БСД и не знаю откуда эта библиотекта. Оперу скачал в tar.bz2 с сайта Оперы.

Оффлайн Snake

  • СтуденТ
  • Hero Member
  • *****
  • Сообщений: 1990
  • Карма: +6/-0
    • БложеГ
Opera 9.64 и FreeBSD 5.2
« Ответ #3 : Август 08, 2009, 01:04:05 am »
И самый лютый зверь, тот знает жалость... я жалости не ведаю... Так значит, я не зверь! (с) Шекспир

Оффлайн kurlyak

  • Newbie
  • *
  • Сообщений: 14
  • Карма: +0/-0
Opera 9.64 и FreeBSD 5.2
« Ответ #4 : Август 08, 2009, 08:21:55 am »
Спасибо за помощь, просто у меня щас под рукой нету ФриБСД 7.2 только 5.2. А вобще советом воспользуюсь.

Оффлайн StranNik

  • Administrator
  • Hero Member
  • *****
  • Сообщений: 8964
  • Карма: +12/-0
  • Логико-интуитивный интроверт
    • http://www.bestforum.ru/forums
Opera 9.64 и FreeBSD 5.2
« Ответ #5 : Август 09, 2009, 09:58:08 pm »
От себя добавлю, что у меня лично со старыми версия особенно с 4 была куча проблем, наверное оттого, что у самого опыт небольшой. А в более новых версиях - ну хотя бы в 6 ветке таких проблем нет. Поищите в своем городе тех, кто может вам записать дистр со свежей версией FreeBSD - как правило это сделают бесплатно за сами болванки или за бутылку пива вовсе незнакомые вам люди :smile:. Достаточно спросить на местном форуме.
Ни богатства, ни избыток роскоши не могут заставить наших врагов любить или уважать нас. Это сделает только страх перед нашим оружием. (с)Вегеций.

Оффлайн kurlyak

  • Newbie
  • *
  • Сообщений: 14
  • Карма: +0/-0
Opera 9.64 и FreeBSD 5.2
« Ответ #6 : Август 11, 2009, 05:28:58 pm »
что вам сказать, господа. Погуглив я обнаружил, что libm.so.3 есть только в 6-й версии ФриБСД и находитсья в пакете compat5x. Естественно я со своим 5-м ФриБСД ничего сделать не смог. Хотя пакет этот скачал и установил эту либу. Заглючил ФриБСД себе. Но, потом я порылся в архиве сайта Опера и скачал Опера 9.24- работает у меня на ФриБСД 5.2 вроде хорошо, без глюков. Но еще тестирую. Правда плугины не находит. Но вобщим я доволен.

Оффлайн StranNik

  • Administrator
  • Hero Member
  • *****
  • Сообщений: 8964
  • Карма: +12/-0
  • Логико-интуитивный интроверт
    • http://www.bestforum.ru/forums
Opera 9.64 и FreeBSD 5.2
« Ответ #7 : Август 11, 2009, 09:45:46 pm »
Ну вот и решение нашлось. Спасибо, что поделились, уверен кому-нибудь еще это пригодится и поможет.  И все же получается если перейти на более актуальную версию FreeBSD, то с кучей проблем просто не встретишься.
Ни богатства, ни избыток роскоши не могут заставить наших врагов любить или уважать нас. Это сделает только страх перед нашим оружием. (с)Вегеций.

Оффлайн kurlyak

  • Newbie
  • *
  • Сообщений: 14
  • Карма: +0/-0
Opera 9.64 и FreeBSD 5.2
« Ответ #8 : Август 14, 2009, 08:32:43 am »
Да так дело в том, что вы представляете- оказываеться в релизе ФриБСД 7.2 есть уже встроенная опера 9.64. Надеюсь все плугины и Флешь плугин тоже там работет. Если бы еще был встроеный Флешь плугин было бы вобще классно.

Оффлайн StranNik

  • Administrator
  • Hero Member
  • *****
  • Сообщений: 8964
  • Карма: +12/-0
  • Логико-интуитивный интроверт
    • http://www.bestforum.ru/forums
Opera 9.64 и FreeBSD 5.2
« Ответ #9 : Август 15, 2009, 09:55:58 pm »
С flash и в линуксах и во фряхе  есть ряд проблем. Но все решаемо :smile:.
Ни богатства, ни избыток роскоши не могут заставить наших врагов любить или уважать нас. Это сделает только страх перед нашим оружием. (с)Вегеций.